Back to overview
Downtime

Algorand Testnet - Outage

Jul 29 at 08:05pm UTC

Resolved
Jul 30 at 12:29pm UTC

The team has successfully restored the service.
We apologize for any inconvenience this may have caused and appreciate your patience during this time.

Created
Jul 29 at 08:05pm UTC

We are currently experiencing an outage with Algorand Testnet.
Our team is investigating the incident.
We will update this incident as soon as we have more information we can share.