RPC Nodes - Service Degraded
Resolved
Apr 10, 2026 at 5:05pm UTC
The service has been stable for the last ~30 min. We will continue monitoring.
Affected services
Updated
Apr 10, 2026 at 4:10pm UTC
The service is recovering across regions. We continue monitoring.
Affected services
Created
Apr 10, 2026 at 3:20pm UTC
We are investigating reports of Service Degraded across chains.
We will provide an update as soon as we have more information we can share.
Affected services