Back to overview
Degraded

Notifications & Data API - Bitcoin Mainnet stuck at block 945191

Apr 15, 2026 at 1:30pm UTC
Affected services
api.tatum.io

Resolved
Apr 15, 2026 at 4:52pm UTC

The service has been reestablished

Created
Apr 15, 2026 at 1:30pm UTC

We are experiencing a service disruption with the bitcoin-mainnet indexer, currently stuck at block 945191. The team is investigating