Back to overview
Downtime

Celo Alfajores (Testnet) - Outage

Mar 12 at 03:28pm UTC
Affected services
celo-testnet.gateway.tatum.io

Resolved
Mar 12 at 05:09pm UTC

The team has observed the network performing well again.
Our nodes are operational.
We appreciate your patience and understanding.

Created
Mar 12 at 03:28pm UTC

We are facing a network issue with Celo Alfajores (Testnet). The nodes are stuck at block 40836335: https://alfajores.celoscan.io/

The team is investigating.