Back to overview
Degraded

BSC (Testnet) - Service Degraded

Jun 06 at 07:20am UTC
Affected services
bsc-testnet.gateway.tatum.io

Resolved
Jun 06 at 08:44am UTC

The chain behaviour has returned to normal.
We will keep monitoring the situation.

Created
Jun 06 at 07:20am UTC

We are currently observing abnormal behavior on the BSC (Testnet) network. Our nodes and fallback infrastructure are consistently returning blocks that are 10–20 minutes ahead of the latest blocks shown in public blockchain explorers.

This discrepancy appears to be network-wide and may impact applications relying on block height consistency or third-party explorers.

Our team is actively monitoring the situation. We will provide further updates as more information becomes available.