Back to overview
Degraded

Polygon Amoy (Testnet) - Service Degraded

Nov 12 at 07:40am UTC
Affected services
Polygon Amoy JSON-RPC

Resolved
Nov 12 at 09:34pm UTC

The service is back to normal.
We appreciate your patience and understanding.

Created
Nov 12 at 07:40am UTC

Polygon Amoy (Testenet) is experiencing a service degraded
We will provide an update as soon as we have more information we can share.