Back to overview
Downtime

Celo Sepolia (Testnet) - Outage

Nov 27 at 12:25pm UTC
Affected services
Celo Sepolia JSON-RPC

Resolved
Nov 27 at 02:32pm UTC

The service has recovered.
We appreciate your patience and understanding.

Created
Nov 27 at 12:25pm UTC

We are experiencing an Outage with Celo Sepolia (Testnet).
The team is investigating.

We will provide an update as soon as we have more information we can share.